Insert Link Not Working in SharePoint 2010?

When trying to insert a link onto a word in a site page on SharePoint 2010, you should see this come up :

But if you’re clicking on Insert Link like a crazy person and nothing is happening, try one of two things.

First hit Save and Close and then Edit again.

Or if that doesn’t work; simply delete the text and retype it, (sometimes you need to enter and type on the line below).   Then select the text and click Insert Link again.

Works every time.


7 responses to “Insert Link Not Working in SharePoint 2010?”

  1. Ayu Avatar
    Ayu

    In 2013,facing the same issue while clicking on insert hyperlink text to display is not coming ………….any guidance

    Like

  2. jtxidrandomno122x Avatar

    Info sangat menarik, sukses ya mas.. , Adrianne

    Like

  3. veroniquepalmer Avatar

    I know – I grimace at the thought. It’s insane how badly some of the functionality in SharePoint 2010 works.

    Like

  4. Ted Avatar

    Try explaining this to a client !!

    Like

  5. veroniquepalmer Avatar

    Why would people do that though?

    Like

  6. Maks Avatar

    Here is another cute bug in SharePoint UI

    http://sharepoint.by/blog/Lists/Posts/Post.aspx?ID=18

    Like

  7. […] Insert Link Not Working in SharePoint 2010? When trying to insert a link onto a word in a site page on SharePoint 2010, you should see this come up : But if you’re clicking on Insert Link like a crazy person and nothing is happening, try one … Continue reading → Read More… […]

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: